<!DOCTYPE html>
<html lang="en" dir="ltr" >

<head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="apple-touch-icon" href="//www.enterprise-tocsin.com/sites/default/files/ET-Favicon_0.png" type="image/png" />
<meta property="og:type" content="Article" /><meta property="og:title" content="Leroy McCurry "/><meta property="og:url" content="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry"/><meta property="og:image" content="//www.enterprise-tocsin.com/sites/default/files/newWebHeaderInvert2 2017_0.png"/><meta property="fb:admins" content="dgustoughson"><meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="/obituaries/leroy-mccurry" />
<link rel="shortlink" href="/node/7779" />
<link rel="shortcut icon" href="//www.enterprise-tocsin.com/sites/default/files/ET-Favicon_0.jpg" type="image/jpeg" />
  <title>Leroy McCurry  | The Enterprise-Tocsin</title>  
  <style type="text/css" media="all">
@import url("//www.enterprise-tocsin.com/modules/system/system.base.css?q5znwa");
@import url("//www.enterprise-tocsin.com/modules/system/system.menus.css?q5znwa");
@import url("//www.enterprise-tocsin.com/modules/system/system.messages.css?q5znwa");
@import url("//www.enterprise-tocsin.com/modules/system/system.theme.css?q5znwa");
</style>
<style type="text/css" media="all">
@import url("//www.enterprise-tocsin.com/misc/ui/jquery.ui.core.css?q5znwa");
@import url("//www.enterprise-tocsin.com/misc/ui/jquery.ui.theme.css?q5znwa");
@import url("//www.enterprise-tocsin.com/misc/ui/jquery.ui.button.css?q5znwa");
@import url("//www.enterprise-tocsin.com/misc/ui/jquery.ui.resizable.css?q5znwa");
@import url("//www.enterprise-tocsin.com/misc/ui/jquery.ui.dialog.css?q5znwa");
</style>
<style type="text/css" media="all">
@import url("//www.enterprise-tocsin.com/modules/aggregator/aggregator.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/calendar/css/calendar_multiday.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/date/date_api/date.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/date/date_popup/themes/datepicker.1.7.css?q5znwa");
@import url("//www.enterprise-tocsin.com/modules/field/theme/field.css?q5znwa");
@import url("//www.enterprise-tocsin.com/modules/node/node.css?q5znwa");
@import url("//www.enterprise-tocsin.com/modules/search/search.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/simpleads/simpleads.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/ubercart/uc_order/uc_order.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/ubercart/uc_product/uc_product.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/ubercart/uc_store/uc_store.css?q5znwa");
@import url("//www.enterprise-tocsin.com/modules/user/user.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/views/css/views.css?q5znwa");
</style>
<style type="text/css" media="all">
@import url("//www.enterprise-tocsin.com/sites/all/modules/ed_classified/theme/classified.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/ctools/css/ctools.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/event_calendar/event_popup/css/event_popup.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/ctools/css/modal.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/modules/responsive_menus/styles/responsive_menus_simple/css/responsive_menus_simple.css?q5znwa");
</style>
<link type="text/css" rel="stylesheet" href="/sites/all/modules/custom/emmerich_notifications/css/style.css" media="all" />
<style type="text/css" media="all">
@import url("//www.enterprise-tocsin.com/sites/all/modules/quicktabs/css/quicktabs.css?q5znwa");
</style>
<style type="text/css" media="all">
@import url("//www.enterprise-tocsin.com/sites/all/themes/bones/css/normalize.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/themes/bones/css/formalize.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/themes/bones/css/grid_12.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/themes/bones/css/layout.css?q5znwa");
</style>
<style type="text/css" media="all">
@import url("//www.enterprise-tocsin.com/sites/default/files/fontyourface/wysiwyg.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/default/files/fontyourface/font.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/themes/current/css/style4.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/themes/current/css/responsive.css?q5znwa");
@import url("//www.enterprise-tocsin.com/sites/all/themes/current/css/custom.css?q5znwa");
</style>
  <script type="text/javascript" src="//www.enterprise-tocsin.com/misc/jquery.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/jquery-extend-3.4.0.js?v=1.4.4"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/jquery.once.js?v=1.2"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
googletag.slots = googletag.slots || {};
//--><!]]>
</script>
<script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/drupal.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.core.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.widget.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.button.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.mouse.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.draggable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.position.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.resizable.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ui/jquery.ui.dialog.min.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/views/js/jquery.ui.dialog.patch.js?v=1.8.7"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/jquery.cookie.js?v=1.0"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/jquery.form.js?v=2.52"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/ajax.js?v=7.66"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/simpleads/simpleads.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/simpleads/modules/simpleads_campaigns/simpleads_campaigns.js?q5znwa"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
googletag.cmd.push(function() {
  googletag.pubads().enableAsyncRendering();
  googletag.pubads().enableSingleRequest();
  googletag.pubads().collapseEmptyDivs();
});

googletag.enableServices();
//--><!]]>
</script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/misc/progress.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/event_calendar/event_popup/js/event_popup.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/event_calendar/event_popup/js/event_popup_validate.js?q5znwa"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function($) { 
    $.expr[':'].regex = function(elem, index, match) {
            var matchParams = match[3].split(','),
            validLabels = /^(data|css):/,
            attr = {
                method: matchParams[0].match(validLabels) ? 
                matchParams[0].split(':')[0] : 'attr',
                property: matchParams.shift().replace(validLabels,'')
            },
            regexFlags = 'ig',
            regex = new RegExp(matchParams.join('').replace(/^\s+|\s+$/g,''), regexFlags);
            return regex.test(jQuery(elem)[attr.method](attr.property));
        }
    });
//--><!]]>
</script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/ctools/js/modal.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/views/js/base.js?q5znwa"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var switchTo5x = true;var useFastShare = true;
//--><!]]>
</script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/views/js/ajax_view.js?q5znwa"></script>
<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (typeof stLight !== 'undefined') { stLight.options({"publisher":"fc937732-3d58-4754-8720-1d210502838c","version":"5x","doNotCopy":false,"hashAddressBar":true,"doNotHash":false,"onhover":false,"newOrZero":"zero","lang":"en"}); }
//--><!]]>
</script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/responsive_menus/styles/responsive_menus_simple/js/responsive_menus_simple.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/google_analytics/googleanalytics.js?q5znwa"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-75225316-7", {"cookieDomain":"auto"});ga("set", "anonymizeIp", true);ga("send", "pageview");
//--><!]]>
</script>
<script type="text/javascript" src="/sites/all/modules/custom/emmerich_notifications/js/script.js"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/fb_likebox/fb_likebox.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/quicktabs/js/quicktabs.js?q5znwa"></script>
<script type="text/javascript" src="//use.edgefonts.net/eb-garamond:n4.js"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/bones/js/jquery.formalize.min.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/bones/js/superfish.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/current/js/scripts.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/bones/js/jquery.easing.1.3.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/bones/js/jquery.equal-height-columns.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/current/js/jquery.mobilemenu.min.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/current/js/jquery.color.js?q5znwa"></script>
<script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/themes/current/js/jquery-glowing.js?q5znwa"></script>
<script type="text/javascript">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</script>
  <meta name="viewport" content="width=device-width, initial-scale=1">  
  <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
  <link href='//fonts.googleapis.com/css?family=Paytone+One' rel='stylesheet' type='text/css'>
  <script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-8039211595423832",
    enable_page_level_ads: true
  });
</script>
<script src="https://cdn.broadstreetads.com/init-2.min.js"></script>
<script>broadstreet.watch({ networkId: 6305 })</script>

</head>

<body class="html not-front not-logged-in one-sidebar sidebar-second page-node page-node- page-node-7779 node-type-article sidebars-split obituaries leroy-mccurry">
  <div id="skip-link">
    <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
  </div>
    <div id="page">

  <div class="user-menu-wrapper"><div class="user-menu-wrapper-inner container_12">  
    <nav id="user-menu" class="grid_12 clearfix">
        <div class="region region-user-menu">
    <div id="block-system-user-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>User menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first last leaf"><a href="/user/login" title=""><span>Login</span></a></li>
</ul>  </div>

</div></div>   </div>
        <div class="region region-search-box">
    <div id="block-search-form" class="block block-search"><div class="block-inner">

	     
  <div class="content">
		<form onsubmit="if(this.search_block_form.value==&#039;Search&#039;){ alert(&#039;Please enter a search&#039;); return false; }" action="/obituaries/leroy-mccurry" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." onblur="if (this.value == &#039;&#039;) {this.value = &#039;Search&#039;;}" onfocus="if (this.value == &#039;Search&#039;) {this.value = &#039;&#039;;}" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-dwYmrT3TkiytPDy3I4AmUkYDYb4H_Qc6bMosz_XrVwM" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>  </div>

</div></div>   </div>
      <div id="social">
        <ul class="social-links">
          <li><a class="rss" href="/rss.xml"></a></li>
          <li><a class="twitter" href="hthttps://twitter.com/IndianolaMSnews"></a></li>
          <li><a class="facebook" href="https://www.facebook.com/enterprisetocsin"></a></li>
        </ul>
      </div>         
    </nav>
  </div></div>

  <div class="header-wrapper"><div class="header-wrapper-inner container_12">
    <header class="grid_12 clearfix">
            <div class="logo-slogan">  
        
                  <div class="site-logo">
            <a href="/"><img src="//www.enterprise-tocsin.com/sites/default/files/newWebHeaderInvert2 2017_0.png" alt="" /></a>
          </div>
        	      
        
        <hgroup>
        
                    
                     
        
        </hgroup> 
  
      </div>

           
    </header>  
    
  </div></div>

      
    <div class="main-menu-wrapper"><div class="main-menu-wrapper-inner container_12">  
      <nav id="main-menu" class="grid_12 clearfix">
          <div class="region region-main-menu">
    <div id="block-system-main-menu" class="block block-system block-menu"><div class="block-inner">

	      <h3 class="title"><span>Main menu</span></h3>
     
  <div class="content">
		<ul class="menu"><li class="first expanded"><a href="/" title="Home"><span>Home</span></a><ul class="menu"><li class="first leaf"><a href="/submit-news"><span>Submit News</span></a></li>
<li class="leaf"><a href="/our-staff" title="Our Staff"><span>Our Staff</span></a></li>
<li class="leaf"><a href="/contact-us" title="Contact Us"><span>Contact Us</span></a></li>
<li class="leaf"><a href="/rack-locations"><span>Where to buy</span></a></li>
<li class="last leaf"><a href="/monthly-website-statistics"><span>Monthly Website Statistics</span></a></li>
</ul></li>
<li class="leaf"><a href="/eedition-front"><span>E-Edition</span></a></li>
<li class="expanded"><a href="/news" title=""><span>News</span></a><ul class="menu"><li class="first leaf"><a href="/breaking-news" title="Breaking News"><span>Breaking News</span></a></li>
<li class="leaf"><a href="/crime" title="Crime"><span>Crime</span></a></li>
<li class="leaf"><a href="/documents" title="Documents"><span>Documents</span></a></li>
<li class="leaf"><a href="/public-notices" title="Public Notices"><span>Public Notices</span></a></li>
<li class="last leaf"><a href="/most-read"><span>Most Read</span></a></li>
</ul></li>
<li class="leaf"><a href="/sports-0" title="Sports"><span>Sports</span></a></li>
<li class="expanded"><a href="/opinion" title="Opinion"><span>Opinion</span></a><ul class="menu"><li class="first leaf"><a href="/columns" title="Columns"><span>Columns</span></a></li>
<li class="leaf"><a href="/comments" title="Comments"><span>Comments</span></a></li>
<li class="leaf"><a href="/editorials" title="Editorials"><span>Editorials</span></a></li>
<li class="last leaf"><a href="/letters" title="Letters"><span>Letters</span></a></li>
</ul></li>
<li class="expanded"><a href="/social" title="Social"><span>Social</span></a><ul class="menu"><li class="first leaf"><a href="/weddings" title="Weddings"><span>Weddings</span></a></li>
<li class="leaf"><a href="/obituaries" title="Obituaries"><span>Obituaries</span></a></li>
<li class="leaf"><a href="/births" title="Births"><span>Births</span></a></li>
<li class="leaf"><a href="/schools" title="Schools"><span>Schools</span></a></li>
<li class="leaf"><a href="/community-calendar" title="Community Calendar"><span>Community Calendar</span></a></li>
<li class="last leaf"><a href="/features" title="Features"><span>Features</span></a></li>
</ul></li>
<li class="last leaf"><a href="http://enterprise-tocsin.com/subscribe" title=""><span>Subscribe</span></a></li>
</ul>  </div>

</div></div>   </div>
      </nav>
    </div></div> 
      
  
  <div class="main-menu-second-level-wrapper clearfix"><div class="main-menu-second-level-wrapper-inner container_12">  
    <nav id="main-menu-second-level" class="grid_12">
            
    </nav>
  </div></div> 
  
<!-- Main Content -->  
  <div class="main-content-wrapper"><div class="main-content-wrapper-inner container_12">
    <section id="main-content" class="clearfix"> 	   

          
    
      <div class="main">
        <div class="main-inner  grid_6">

                
	      
        
                                          
          <div class="main-inner-wrp">
            <div class="region region-content-top">
    <div id="block-block-62" class="block block-block adServeMargin hideFeed"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_top_leaderboard" zone-id="75259"></broadstreet-zone></p>
   </div>

</div></div>   </div>
                                          <div class="region region-content">
    <div id="block-system-main" class="block block-system"><div class="block-inner">

	     
  <div class="content">
		<article id="node-7779" class="node node-article node-promoted last clearfix">



  


  


  <div class="node-content-wrapper">



    


      


      
       <h1 class="title">Leroy McCurry </h1>

      


    


    


    
        <ul class="links inline"><li class="statistics_counter first last"><span>305 reads</span></li>
</ul>
    


    
      <div class="submitted">

            <span class="date">Tue, 05/05/2020 - 9:39am</span>

      </div>

    


    <div class="content">

    <div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even"> <p>Graveside services for Leroy McCurry of Indianola will be at 11 a.m. Saturday at Riverside Memorial Gardens.</p>
<p>Mr. McCurry, 66, died Sunday, May 3, 2020.</p>
<p>Byas Funeral Home is in charge of arrangements.</p>
<p>Mr. McCurry is survived by: two sons, Laron (Dionne) McCurry of Zachary, La. and Lorenzo (Lawanda) Cotton of Ruleville; two daughters, Keisha (Marcus) Jones and Kavarica (Rodney) Whitley, both of Indianola; eight brothers, J.B. Brown, Archie McCurry and Cornelius McCurry, all of Indianola, L.T. McCurry, Essex Fair and Atris Fair, all of Dallas, Clarence McCurry of Chicago and Tony Fair of Jackson; three sisters, Ethel Benson of Atlanta and Sandra Jones and Melinda Fair, both of Jackson; and a host of other relatives and friends.</p>
<p>Graveside services for Leroy McCurry of Indianola will be at 11 a.m. Saturday at Riverside Memorial Gardens with the Rev. Dr. C.W. Ray officiating.</p>
 </div></div></div><div class="item-list"><ul class="pager-for-content-type flippy"><li class="pager-previous prev first"><a href="/obituaries/howard-thomas-ellis#node-7778" class="prev"><span>‹ Previous</span></a></li>
<li class="pager-next next last"><a href="/obituaries/brenda-jean-cobb-roberts#node-7780" class="next"><span>Next ›</span></a></li>
</ul></div>
    </div>







    
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


  
      <nav class="taxonomy"><div class="taxonomy-inner clearfix">

        
      </div></nav>

    


 






  </div>





</article>




  </div>

</div></div> <div id="block-sharethis-sharethis-block" class="block block-sharethis"><div class="block-inner">

	     
  <div class="content">
		<div class="sharethis-wrapper"><span st_url="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry" st_title="Leroy McCurry " class="st_facebook_button" displayText="facebook"></span>
<span st_url="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry" st_title="Leroy McCurry " class="st_twitter_button" displayText="twitter" st_via="" st_username=""></span>
<span st_url="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry" st_title="Leroy McCurry " class="st_pinterest_button" displayText="pinterest" st_via="" st_username=""></span>
<span st_url="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry" st_title="Leroy McCurry " class="st_tumblr_button" displayText="tumblr" st_via="" st_username=""></span>
<span st_url="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry" st_title="Leroy McCurry " class="st_email_button" displayText="email" st_via="" st_username=""></span>
<span st_url="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry" st_title="Leroy McCurry " class="st_fblike_button" displayText="fblike" st_via="" st_username=""></span>
</div>  </div>

</div></div> <div id="block-facebook-comments-box-facebook-comments-box" class="block block-facebook-comments-box"><div class="block-inner">

	     
  <div class="content">
		<div class="facebook-comments-box"><div id="fb-root"></div><script src="http://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:comments href="https://www.enterprise-tocsin.com/obituaries/leroy-mccurry"  num_posts="10"  width="580"  colorscheme="light" ></fb:comments></div>  </div>

</div></div>   </div>
  
                  
                              </div>
        </div> 
                <aside class="sidebar second-sidebar grid_6">
          <div class="sidebar-wrp">
              <div class="region region-second-ad">
    <div id="block-block-75" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<p><center><broadstreet-zone soft-keywords="true" uri-keywords="true" zone-id="76977"></broadstreet-zone></center></p>  </div>

</div></div> <div id="block-block-45" class="block block-block sign-up-for-emmerich-notifications"><div class="block-inner">

	      <h3 class="title"><span>Sign Up for Notifications of Local Breaking News</span></h3>
     
  <div class="content">
		<p><a class="ctools-use-modal start" href="/emmerich/subscribe/email/js">Start E-mail Notifications</a></p>
<p><a class="ctools-use-modal stop" href="/emmerich/unsubscribe/email-popup/js">Stop E-mail Notifications</a></p>
<p><a class="ctools-use-modal start" href="/emmerich/subscribe/mobile/js">Start Mobile Notifications</a></p>
<p><a class="ctools-use-modal stop" href="/emmerich/unsubscribe/mobile/js">Stop Mobile Notifications</a></p>  </div>

</div></div> <div id="block-simpleads-ad-groups-148" class="block block-simpleads"><div class="block-inner">

	     
  <div class="content">
		<div class="header">
  <div class="ad-link"></div>
</div>
<div class="adslist">
  <script type="text/javascript">
    _simpelads_load('.simpleads-148', 148, 1);
  </script>
    <div class="simpleads-148"></div>

    
</div>
  </div>

</div></div> <div id="block-block-46" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_1_skyscraper_medium_rectangle" zone-id="75431"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-44" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><a href="/most-read"><img alt="" src="https://www.enterprise-tocsin.com/sites/default/files/Most-Read-Stories_new.jpg" style="width: 300px; height: 400px;" /></a></p>
   </div>

</div></div> <div id="block-block-47" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_2_skyscraper_medium_rectangle" zone-id="75036"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-48" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_3_skyscraper_medium_rectangle" zone-id="75723"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-49" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_4_skyscraper_medium_rectangle" zone-id="75332"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-50" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_5_skyscraper_medium_rectangle" zone-id="74414"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-51" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_6_skyscraper_medium_rectangle" zone-id="74415"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-52" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_bottom_skyscraper_medium_rectangle" zone-id="75032"></broadstreet-zone></p>
   </div>

</div></div>   </div>
              <div class="region region-sidebar-second">
    <div id="block-fb-likebox-0" class="block block-fb-likebox adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<div class="fb-page" data-href="https://www.facebook.com/enterprisetocsin" data-width="300" data-height="500" data-tabs="timeline" data-hide-cover="0" data-show-facepile="1" data-hide-cta="0" data-small-header="0" data-adapt-container-width="1"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/enterprisetocsin"><a href="https://www.facebook.com/enterprisetocsin"><span>Like us on Facebook</span></a></blockquote></div></div>  </div>

</div></div> <div id="block-block-34" class="block block-block adServeMargin"><div class="block-inner">

	     
  <div class="content">
		<!-- Medium Rectangle [async] -->
<script type="text/javascript">if (!window.AdButler){(function(){var s = document.createElement("script"); s.async = true; s.type = "text/javascript";s.src = 'https://servedbyadbutler.com/app.js';var n = document.getElementsByTagName("script")[0]; n.parentNode.insertBefore(s, n);}());}</script>
<script type="text/javascript">
var AdButler = AdButler || {}; AdButler.ads = AdButler.ads || [];
var abkw = window.abkw || '';
var plc293873 = window.plc293873 || 0;
document.write('<'+'div id="placement_293873_'+plc293873+'"></'+'div>');
AdButler.ads.push({handler: function(opt){ AdButler.register(171437, 293873, [300,250], 'placement_293873_'+opt.place, opt); }, opt: { place: plc293873++, keywords: abkw, domain: 'servedbyadbutler.com', click:'CLICK_MACRO_PLACEHOLDER' }});
</script>
  </div>

</div></div>   </div>
  
          </div>                 
        </aside>
             
      </div>            
  
    </section>
  </div></div>
  
    
    <div class="preface-wrapper"><div class="preface-wrapper-inner container_12">  
      <section id="preface" class="clearfix">
        <div class="grid_6">  <div class="region region-preface-1">
    <div id="block-block-53" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_top_left_widget_medium_rectangle" zone-id="74417"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-views-sports-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Sports</span></h3>
     
  <div class="content">
		<div class="view view-sports view-id-sports view-display-id-block view-dom-id-7b6c55a9db79c2a6cc765197e644c0f9">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/front-page-slideshow-news-sports/anthony-davis-brings-20-years-experience-coaching-boys-basketball"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/IMG_4330.jpg?itok=6jsGjC0X" width="100" height="63" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/front-page-slideshow-news-sports/anthony-davis-brings-20-years-experience-coaching-boys-basketball"><span>Anthony Davis brings 20 years experience coaching boys basketball</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Coaching changes can be hard on a program but many times those transitions can be exciting.</span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-sports view-id-sports view-display-id-attachment_1">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-54" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_left_widget_medium_rectangle" zone-id="74468"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-quicktabs-most-read-headline" class="block block-quicktabs"><div class="block-inner">

	      <h3 class="title"><span>Most Read - Headline</span></h3>
     
  <div class="content">
		<div  id="quicktabs-most_read_headline" class="quicktabs-wrapper quicktabs-style-nostyle"><div class="item-list"><ul class="quicktabs-tabs quicktabs-style-nostyle"><li class="active first"><a href="/obituaries/leroy-mccurry?qt-most_read_headline=0#qt-most_read_headline" id="quicktabs-tab-most_read_headline-0" class="active"><span>Week</span></a></li>
<li><a href="/obituaries/leroy-mccurry?qt-most_read_headline=1#qt-most_read_headline" id="quicktabs-tab-most_read_headline-1" class="active"><span>Month</span></a></li>
<li><a href="/obituaries/leroy-mccurry?qt-most_read_headline=2#qt-most_read_headline" id="quicktabs-tab-most_read_headline-2" class="active"><span>Year</span></a></li>
<li class="last"><a href="/obituaries/leroy-mccurry?qt-most_read_headline=3#qt-most_read_headline" id="quicktabs-tab-most_read_headline-3" class="active"><span>All Time</span></a></li>
</ul></div><div id="quicktabs-container-most_read_headline" class="quicktabs_main quicktabs-style-nostyle"><div  id="quicktabs-tabpage-most_read_headline-0" class="quicktabs-tabpage "><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_1 view-dom-id-60cf4c2b19f428cae8517cf552daff1c">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/news/great-comfort"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/Wade Dowell web.jpg?itok=dVCxFBv3" width="100" height="63" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/news/great-comfort?most_read_source=week"><span>A great comfort</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/mississippi-catfish-industry-likely-benefit-usda-surplus-purchase?most_read_source=week"><span>Mississippi catfish industry likely to benefit from USDA surplus purchase</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/nearly-700-tested-covid-19-indianola-week?most_read_source=week"><span>Nearly 700 tested for COVID-19 in Indianola this week</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/%E2%80%98i-was-really-scared%E2%80%99indianola-native-talks-about-three-week-quarantine?most_read_source=week"><span>‘I was really scared’:Indianola native talks about three-week quarantine, dealing with virus symptoms</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/chris-grant-owner-nola-talks-about-success-his-downtown-indianola?most_read_source=week"><span>Chris Grant, owner of Nola, talks about the  success of his downtown Indianola restaurant</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/virus-could-take-toll-city-budget?most_read_source=week"><span>Virus could take toll on city budget</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/leroy-mccurry?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/leroy-mccurry?page=0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/leroy-mccurry?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/leroy-mccurry?page=0%2C0%2C7">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-1" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_2 view-dom-id-4b652310b3326018dc7c403e55c67248">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/three-arrested-one-sought-friday-night-shooting-death"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/Mugs.jpg?itok=lTw_aEuf" width="100" height="63" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/three-arrested-one-sought-friday-night-shooting-death?most_read_source=month"><span>Three arrested, one sought in Friday night shooting death</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/loved-ones-remember-young-woman-shot-and-killed-last-friday?most_read_source=month"><span>Loved ones remember young woman shot and killed last Friday</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/young-woman-shot-and-killed-indianola-tonight?most_read_source=month"><span>Young woman shot and killed in Indianola tonight</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/news/great-comfort?most_read_source=month"><span>A great comfort</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/police-fourth-suspect-garner-shooting-death-now-custody?most_read_source=month"><span>Police: Fourth suspect in Garner shooting death now in custody</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/gresham-named-restart-mississippi-executive-team?most_read_source=month"><span>Gresham named to Restart Mississippi Executive Team</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/leroy-mccurry?page=0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/leroy-mccurry?page=0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/leroy-mccurry?page=0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/leroy-mccurry?page=0%2C0%2C28">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-2" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block view-dom-id-51a70915cb5bb75e0cfedf94a12139e5">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/news/county-conveys-land-plans-move-forward-new-33m-wellness-center-next-ssch"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/SSCH logo.jpg?itok=P-0pF2JQ" width="100" height="63" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/news/county-conveys-land-plans-move-forward-new-33m-wellness-center-next-ssch?most_read_source=year"><span>County conveys land as plans move forward for new $3.3M wellness center next to SSCH</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/opinion-editorials-columns/job-fair-good-case-study?most_read_source=year"><span>Job fair a good case study</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/16-year-old-charged-adult-17-year-olds-christmas-eve-shooting-death?most_read_source=year"><span>16-year-old charged as adult in 17-year-old&#039;s Christmas Eve shooting death</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/opinion-columns/king-and-parchman-elvis%E2%80%99-dad-spent-nine-months-sunflower-county-prison-late-30s?most_read_source=year"><span>The King and Parchman: Elvis’ dad spent nine months in the Sunflower County prison in the late 30s</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/roundaway-baptist-church-turns-100?most_read_source=year"><span>Roundaway Baptist Church turns 100</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/new-faces-double-quick-transaction-won%E2%80%99t-happen-until-spring-refuel?most_read_source=year"><span>Men behind pending Double Quick buy detail plans</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/leroy-mccurry?page=1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/leroy-mccurry?page=2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/leroy-mccurry?page=1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/leroy-mccurry?page=344">last »</a></li>
</ul></div>  
  
  
  
  
</div></div><div  id="quicktabs-tabpage-most_read_headline-3" class="quicktabs-tabpage quicktabs-hide"><div class="view view-most-read-headline view-id-most_read_headline view-display-id-block_3 view-dom-id-d9097c6cf8a602122607e0d85e03bfcc">
        
  
  
      <div class="view-content">
      
  
  
  <div class="views-row views-row-1 views-row-odd views-row-first">
    <div class="views-field views-field-field-image"><div class="field-content"><a href="/front-page-slideshow-news/fumc-praise-band-releases-second-studio-album"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/Reagan Daniels 2 web.jpg?itok=eFtGVE_z" width="100" height="63" alt="" /></span></a></div></div><div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/fumc-praise-band-releases-second-studio-album?most_read_source=all"><span>FUMC praise band releases second studio album</span></a></span></div>  </div>
  
      <div class="attachment">
  
  <div class="views-row views-row-2 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/mdcc-alumni-event-golf-tournament-month?most_read_source=all"><span>MDCC alumni event, golf tournament this month</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-3 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/mdcc-open-bids-stauffer-wood-renovation?most_read_source=all"><span>MDCC to open bids for Stauffer-Wood renovation</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-4 views-row-even">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/rasberry-men-present-black-history-program?most_read_source=all"><span>Rasberry men to present black history program</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-5 views-row-odd">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/candidates-meet-public-forum?most_read_source=all"><span>Candidates meet in public forum</span></a></span></div>  </div>
  
  
  <div class="views-row views-row-6 views-row-even views-row-last">
    <div class="views-field views-field-title"><span class="field-content"><a href="/front-page-slideshow-news/church-encourages-athletes-%E2%80%98pursue-god%E2%80%99?most_read_source=all"><span>Church encourages athletes to ‘pursue God’</span></a></span></div>  </div>

</div>
    </div>
  
      <h2 class="element-invisible">Pages</h2><div class="item-list"><ul class="pager"><li class="pager-current first">1</li>
<li class="pager-item"><a title="Go to page 2" href="/obituaries/leroy-mccurry?page=0%2C0%2C0%2C1">2</a></li>
<li class="pager-item"><a title="Go to page 3" href="/obituaries/leroy-mccurry?page=0%2C0%2C0%2C2">3</a></li>
<li class="pager-ellipsis">…</li>
<li class="pager-next"><a title="Go to next page" href="/obituaries/leroy-mccurry?page=0%2C0%2C0%2C1">next ›</a></li>
<li class="pager-last last"><a title="Go to last page" href="/obituaries/leroy-mccurry?page=0%2C0%2C0%2C795">last »</a></li>
</ul></div>  
  
  
  
  
</div></div></div></div>  </div>

</div></div> <div id="block-block-55" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_bottom_left_widget_medium_rectangle" zone-id="74407"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-views-social-recent-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Social</span></h3>
     
  <div class="content">
		<div class="view view-social-recent-stories view-id-social_recent_stories view-display-id-block view-dom-id-70bc582db49c66e8b026f55b3834d245">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/social-weddings/sykes-daniels-wed-march-7"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/Daniels web_0.jpg?itok=adbIm0Zy" width="100" height="63" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/social-weddings/sykes-daniels-wed-march-7"><span>Sykes, Daniels to wed March 7</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Mr. and Mrs. Andy Daniels of Indianola announce the engagement of their daughter, Sara Anna... <a href="/social-weddings/sykes-daniels-wed-march-7" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-social-recent-stories view-id-social_recent_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/social-births/birth-announcement-catherine-%E2%80%9Crin%E2%80%9D-everett-greenlee"><span>Birth Announcement: Catherine “Rin” Everett Greenlee </span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/social-weddings/long-davis-exchange-vows"><span>Long, Davis exchange vows</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/social-weddings/freeman-mcdowell-wed-oct-26"><span>Freeman, McDowell to wed Oct. 26</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/social-weddings/lott-muncher-exchange-vows"><span>Lott, Muncher to exchange vows</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/social-weddings/howard-wed-harrell-august-17"><span>Howard to wed Harrell on August 17</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-56" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_top_right_widget_medium_rectangle" zone-id="75606"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-57" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_right_widget_medium_rectangle" zone-id="75494"></broadstreet-zone></p>
   </div>

</div></div>   </div>
</div>
        <div class="grid_6">  <div class="region region-preface-2">
    <div id="block-block-58" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_top_middle_widget_medium_rectangle" zone-id="75474"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-views-business-top-stories-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Opinion</span></h3>
     
  <div class="content">
		<div class="view view-business-top-stories view-id-business_top_stories view-display-id-block view-dom-id-992bd91d33922a13b31f5e33da17feba">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/opinion-editorials-columns/virus-attacks-most-vulnerable"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/Bryan Mug web_78.jpg?itok=HkC9QIUj" width="100" height="63" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-editorials-columns/virus-attacks-most-vulnerable"><span>Virus attacks the most vulnerable</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> COVID-19 can literally choke the life out of an individual by attacking the lungs.</span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-business-top-stories view-id-business_top_stories view-display-id-attachment_1">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columns/are-garden-lines-decision-or-default"><span>Are garden lines by decision or default?</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-2 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columns/precious-memories%E2%80%A6how-they-linger"><span>Precious Memories…how they linger</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-3 views-row-odd">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columns/pages-past-update-drew-mcdowell"><span>Pages from the past: Update on Drew McDowell</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-4 views-row-even">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-columns/what-do-now-corona-quarantine-blues"><span>What To Do Now? Corona Quarantine Blues</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
    <div class="views-row views-row-5 views-row-odd views-row-last">
      
  <div class="views-field views-field-title">        <span class="field-content"><a href="/opinion-editorials-columns/dunagin-political-news-would-be-welcomed"><span>Dunagin: Political news would be welcomed</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-59" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_middle_middle_widget_medium_rectangle" zone-id="74418"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-views-obituaries-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Obituaries</span></h3>
     
  <div class="content">
		<div class="view view-obituaries view-id-obituaries view-display-id-block view-dom-id-60edf9d4445d54c93dd2561f4094c02f">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"><a href="/obituaries/ellen-smith"><span><img src="//www.enterprise-tocsin.com/sites/default/files/styles/thumbnail/public/field/image/Ellen Smith.jpg?itok=wy_4u3cc" width="100" height="63" alt="" /></span></a></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/obituaries/ellen-smith"><span>Ellen Smith</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Ellen Smith, 78, of Dallas, Texas passed away Sunday, May 3, 2020. </span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-obituaries view-id-obituaries view-display-id-attachment_1">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-60" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_bottom_middle_widget_medium_rectangle" zone-id="74408"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-views-breaking-news-block" class="block block-views"><div class="block-inner">

	      <h3 class="title"><span>Breaking News</span></h3>
     
  <div class="content">
		<div class="view view-breaking-news view-id-breaking_news view-display-id-block view-dom-id-bf786ae3c3f6bd29576b2851373cb474">
        
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last">
      
  <div class="views-field views-field-field-image">        <div class="field-content"></div>  </div>  
  <div class="views-field views-field-title">        <span class="field-content"><a href="/news-breaking-news/video-sccsd-head-talks-schools-closing"><span>VIDEO: SCCSD Head talks schools closing</span></a></span>  </div>  
  <div class="views-field views-field-body">        <span class="field-content"> Sunflower County Consolidated Schools Superintendent talks about the closure of schools during the... <a href="/news-breaking-news/video-sccsd-head-talks-schools-closing" class="views-more-link"><span>READ MORE</span></a></span>  </div><hr style="margin-bottom: 20px;">    
  </div>
      </div>
  
  
      <div class="attachment attachment-after">
      <div class="view view-breaking-news view-id-breaking_news view-display-id-attachment_1">
        
  
  
  
  
  
  
  
  
</div>    </div>
  
  
  
  
</div>  </div>

</div></div> <div id="block-block-61" class="block block-block thinblock"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-alias="ent_bottom_right_widget_medium_rectangle" zone-id="75733"></broadstreet-zone></p>
   </div>

</div></div>   </div>
</div>
        <div class="grid_0"></div>
        <div class="grid_0"></div>
      </section>
          </div></div>  
     
   
    
<!-- All Hail the Footer -->
  <div class="footer-wrapper"><div class="footer-wrapper-inner container_12">
    <footer id="footer" class="grid_12 clearfix">
        <div class="region region-footer">
    <div id="block-block-3" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p style="font-size: 13.008px;" align="center"><span style="font-size: 11px;">Copyright 207 • The Enterprise-Tocsin<br />114 Main St. • Indianola, MS 38751 • (662) 887-2222</span></p>
<p style="font-size: 13.008px;" align="center"><span style="font-size: 11px;">Emmerich Newspapers proudly serve the following Mississippi communities:</span></p>
<p style="font-size: 13.008px;" align="center"><span style="font-size: 11px;">ACKERMAN • CARROLLTON • CHARLESTON • CLARKSDALE • COLUMBIA • EUPORA • FOREST • GREENVILLE • GREENWOOD • HATTIESBURG • JACKSON • KOSCIUSKO • INDIANOLA • LOUISVILLE • MAGEE • MENDENHALL • McCOMB • NEWTON • PETAL • QUITMAN • WINONA • YAZOO CITY</span></p>
<p style="font-size: 13.008px;" align="center"><span style="font-size: 11px;">As well as: DUMAS, Ark. • TALLULAH, La. • FRANKLINTON, La.</span></p>
<p style="font-size: 13.008px;" align="center"><span style="font-size: 11px;">For more information on how to extend your advertising message to these communities, <a href="http://emmerichtestserver1.com/emmerich-contact-form">click here.</a></span></p>
   </div>

</div></div> <div id="block-block-76" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		 <p><broadstreet-zone zone-id="77182"></broadstreet-zone></p>
   </div>

</div></div> <div id="block-block-77" class="block block-block"><div class="block-inner">

	     
  <div class="content">
		<broadstreet-zone zone-id="77184"></broadstreet-zone>
  </div>

</div></div>   </div>
      
    </footer><!-- /footer -->
  </div></div>
 
</div><!-- page -->  <script type="text/javascript" src="//www.enterprise-tocsin.com/sites/all/modules/addthis/addthis.js?q5znwa"></script>
</body>

</html>